summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 12:11:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:40 +0200
commit7edb3a77adc8317e30458d867cf8656a6ebf081b (patch)
tree33634a868bdda80c9abcea38b83dee09949183e8 /dev-ros/dynamic_reconfigure
parentdev-ros/pluginlib: bump to 1.10.5 (diff)
downloadgentoo-7edb3a77adc8317e30458d867cf8656a6ebf081b.tar.gz
gentoo-7edb3a77adc8317e30458d867cf8656a6ebf081b.tar.bz2
gentoo-7edb3a77adc8317e30458d867cf8656a6ebf081b.zip
dev-ros/dynamic_reconfigure: Bump to 1.5.47
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/dynamic_reconfigure')
-rw-r--r--dev-ros/dynamic_reconfigure/Manifest1
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.47.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/Manifest b/dev-ros/dynamic_reconfigure/Manifest
index f29aee228545..2473a463ce9b 100644
--- a/dev-ros/dynamic_reconfigure/Manifest
+++ b/dev-ros/dynamic_reconfigure/Manifest
@@ -1 +1,2 @@
DIST dynamic_reconfigure-1.5.46.tar.gz 35500 SHA256 c3d782715f16c0ec3335e23d27ddb62f12eec3492e865003168c74bd212a6fbb SHA512 9f69ecb0d8bfda8d3f8512009743343c51598c4c886a12eec771ed5e48dacbd363e661c50118e279628a4b198966823c9a9fc8f5fcfa84e7fc307d180a2c1ec6 WHIRLPOOL f7333c92fc3e8fdf0119c4af83c22dca9b98158862be4da084ac439c8a2b7c9e6e3cd99352a40b86a4aee27f28d7a87f79e3102f401cee19ca2f0783abf3c8b7
+DIST dynamic_reconfigure-1.5.47.tar.gz 38650 SHA256 d0c64e0cea268a532c3f5f14d8c9bfc7ad405b47683fa8e7054264d979d4ffd4 SHA512 46a3a8e930a32e02113594777f36beb225028aef17decc6a45413e80a47bafea34587bbf017a1c7bcfcb697332cddf7fd38908d20951831865f36f71a1548727 WHIRLPOOL 5f1632716af160d19141ce4aa4360744d59e533e783bd286cd86e729aa0294f2d46543efb1847dd6a88958b34b5287f62e56af9f20b9b098e147dda6725ae8cd
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.47.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.47.ebuild
new file mode 100644
index 000000000000..9650a1395bcb
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.47.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"