summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-16 12:53:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-16 13:03:26 +0200
commit0c8f7e26d848bb9ac3b29fc8f3b0e732646fc04f (patch)
treeef7c4457d6192a4aa4b160a8b9d39256052dc849 /dev-ros/gazebo_ros/gazebo_ros-2.8.4.ebuild
parentdev-ros/gazebo_plugins: Bump to 2.8.4. (diff)
downloadgentoo-0c8f7e26d848bb9ac3b29fc8f3b0e732646fc04f.tar.gz
gentoo-0c8f7e26d848bb9ac3b29fc8f3b0e732646fc04f.tar.bz2
gentoo-0c8f7e26d848bb9ac3b29fc8f3b0e732646fc04f.zip
dev-ros/gazebo_ros: Bump to 2.8.4.
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'dev-ros/gazebo_ros/gazebo_ros-2.8.4.ebuild')
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.8.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.8.4.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.8.4.ebuild
new file mode 100644
index 000000000000..ca217b085352
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"