summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-28 13:54:22 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-28 13:54:35 +0100
commit06269fd80b4741e25287a1b4834f821aff8422b2 (patch)
treef9ed62e07a680b17c32cf815145498900ecc736d /dev-ros/gazebo_ros_control/gazebo_ros_control-2.7.3.ebuild
parentdev-ros/gazebo_ros: backport upstream fixes to build with gazebo 9 (diff)
downloadgentoo-06269fd80b4741e25287a1b4834f821aff8422b2.tar.gz
gentoo-06269fd80b4741e25287a1b4834f821aff8422b2.tar.bz2
gentoo-06269fd80b4741e25287a1b4834f821aff8422b2.zip
dev-ros/gazebo_ros_control: backport upstream fixes to buidl with gazebo 9
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-ros/gazebo_ros_control/gazebo_ros_control-2.7.3.ebuild')
-rw-r--r--dev-ros/gazebo_ros_control/gazebo_ros_control-2.7.3.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-ros/gazebo_ros_control/gazebo_ros_control-2.7.3.ebuild b/dev-ros/gazebo_ros_control/gazebo_ros_control-2.7.3.ebuild
index e824028e5285..0a2bc106d8c0 100644
--- a/dev-ros/gazebo_ros_control/gazebo_ros_control-2.7.3.ebuild
+++ b/dev-ros/gazebo_ros_control/gazebo_ros_control-2.7.3.ebuild
@@ -6,7 +6,7 @@ ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
KEYWORDS="~amd64"
ROS_SUBDIR=${PN}
-inherit ros-catkin
+inherit ros-catkin eutils
DESCRIPTION="ROS control plugins for gazebo"
LICENSE="BSD"
@@ -31,3 +31,12 @@ RDEPEND="
dev-libs/console_bridge:=
"
DEPEND="${RDEPEND}"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gazebo-ros-2.7.3-patches-1.tar.bz2"
+
+src_prepare() {
+ pushd "${WORKDIR}/gazebo_ros_pkgs-${PV}" || die
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ popd || die
+ ros-catkin_src_prepare
+}