summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 10:37:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 10:37:14 +0200
commitcff2e889c50cddc210d9c966219c8d4da73d9e3a (patch)
tree2d5dd264b84b47f583b9c404ab2106f500287dfb /dev-ros/genmsg/genmsg-9999.ebuild
parenteclass: Add ros-catkin.eclass. (diff)
downloadgentoo-cff2e889c50cddc210d9c966219c8d4da73d9e3a.tar.gz
gentoo-cff2e889c50cddc210d9c966219c8d4da73d9e3a.tar.bz2
gentoo-cff2e889c50cddc210d9c966219c8d4da73d9e3a.zip
dev-ros/genmsg: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/genmsg/genmsg-9999.ebuild')
-rw-r--r--dev-ros/genmsg/genmsg-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/genmsg/genmsg-9999.ebuild b/dev-ros/genmsg/genmsg-9999.ebuild
new file mode 100644
index 000000000000..d70c53c0941d
--- /dev/null
+++ b/dev-ros/genmsg/genmsg-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/genmsg"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Python library for generating ROS message and service data structures for various languages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"