summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 10:56:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:12 +0200
commit4dfa847023c5e4b5e100999988bf8abd467fd39e (patch)
tree0c14972d4e8903b3a5b082b7ec3f5e3139c71a96 /dev-ros/geodesy
parentdev-ros/laser_cb_detector: remove now unused patches (diff)
downloadgentoo-4dfa847023c5e4b5e100999988bf8abd467fd39e.tar.gz
gentoo-4dfa847023c5e4b5e100999988bf8abd467fd39e.tar.bz2
gentoo-4dfa847023c5e4b5e100999988bf8abd467fd39e.zip
dev-ros/geodesy: update py3 patch
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/geodesy')
-rw-r--r--dev-ros/geodesy/Manifest1
-rw-r--r--dev-ros/geodesy/files/py3.patch28
-rw-r--r--dev-ros/geodesy/geodesy-0.5.5.ebuild35
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
index 6e4508144646..b1e2b4acf3d4 100644
--- a/dev-ros/geodesy/Manifest
+++ b/dev-ros/geodesy/Manifest
@@ -1,2 +1 @@
-DIST geographic_info-0.5.5.tar.gz 27762 BLAKE2B 9235911d6a2b010e47722268f5aa14b2bd10dac73bf4445bcd6585c5094947e9ea43ee2ccb6d6a3b0ae788d149fcc546e6618f0097e4bde32d69ed9baacbf255 SHA512 a1699778cd85960603435e7b7d46831c7c5ac4b57f4a06e9f394933799151a5ebf95c59bc109ca05eeb9376763aae8c77bc9150081c81170f1778730145910ec
DIST geographic_info-0.5.6.tar.gz 28130 BLAKE2B 4d7013543db91c02c470c6b6dcb6e00070d5356f91ace20b3bb97aafa71eff2b525fc11994796f2de103b1df40efe8358d19a7e8fc0b1290c73cc28c791f22ce SHA512 d2f41320d2b094c2ea04593941e35d2b5581b84cc2f599099880dd671255dd59bc8787ad4a5640539cc25a13592df2ec7a887e3ea171398cfeafeccc669bd7f0
diff --git a/dev-ros/geodesy/files/py3.patch b/dev-ros/geodesy/files/py3.patch
index 08259ee976c1..66ef4e5dd3ca 100644
--- a/dev-ros/geodesy/files/py3.patch
+++ b/dev-ros/geodesy/files/py3.patch
@@ -1,31 +1,3 @@
-Index: geodesy/src/geodesy/wu_point.py
-===================================================================
---- geodesy.orig/src/geodesy/wu_point.py
-+++ geodesy/src/geodesy/wu_point.py
-@@ -159,12 +159,12 @@ class WuPointSet():
- # Initialize way point information.
- self.way_point_ids = {} # points symbol table
- self.n_points = len(self.points)
-- for wid in xrange(self.n_points):
-+ for wid in range(self.n_points):
- self.way_point_ids[self.points[wid].id.uuid] = wid
-
- # Create empty list of UTM points, corresponding to map points.
- # They will be evaluated lazily, when first needed.
-- self.utm_points = [None for wid in xrange(self.n_points)]
-+ self.utm_points = [None for wid in range(self.n_points)]
-
- def __contains__(self, item):
- """ Point set membership. """
-@@ -259,7 +259,7 @@ class WuPointSet():
- """
- return self.way_point_ids.get(key, default)
-
-- def next(self):
-+ def __next__(self):
- """ Next iteration point.
-
- :returns: Next :class:`WuPoint`.
Index: geodesy/tests/test_wu_point.py
===================================================================
--- geodesy.orig/tests/test_wu_point.py
diff --git a/dev-ros/geodesy/geodesy-0.5.5.ebuild b/dev-ros/geodesy/geodesy-0.5.5.ebuild
deleted file mode 100644
index 88ea377b0cc7..000000000000
--- a/dev-ros/geodesy/geodesy-0.5.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
-KEYWORDS="~amd64"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/angles
- dev-ros/geographic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/tf
- dev-ros/unique_id
- dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? (
- dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
- dev-cpp/gtest
- $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
- )"
-PATCHES=( "${FILESDIR}/py3.patch" )