summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-27 11:09:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-27 11:26:01 +0200
commitd4333a4c699b3861c954b0de7d4a5509b677540b (patch)
treed3146e4dc516cafa3fee36c40db4c771cc184184 /dev-ros/global_planner/global_planner-1.16.0.ebuild
parentdev-ros/fake_localization: Bump to 1.16.0. (diff)
downloadgentoo-d4333a4c699b3861c954b0de7d4a5509b677540b.tar.gz
gentoo-d4333a4c699b3861c954b0de7d4a5509b677540b.tar.bz2
gentoo-d4333a4c699b3861c954b0de7d4a5509b677540b.zip
dev-ros/global_planner: Bump to 1.16.0.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ros/global_planner/global_planner-1.16.0.ebuild')
-rw-r--r--dev-ros/global_planner/global_planner-1.16.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/global_planner/global_planner-1.16.0.ebuild b/dev-ros/global_planner/global_planner-1.16.0.ebuild
new file mode 100644
index 000000000000..309d248922f0
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-1.16.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+
+ dev-ros/angles
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"