summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 16:29:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 17:12:24 +0100
commite53aeee07189201914a71b73dca68ff892f41eb0 (patch)
treeaed515496338a47bd7a835dd1794d3d65675a35b /dev-ros/global_planner/global_planner-1.16.3.ebuild
parentdev-ros/fake_localization: Bump to 1.16.3. (diff)
downloadgentoo-e53aeee07189201914a71b73dca68ff892f41eb0.tar.gz
gentoo-e53aeee07189201914a71b73dca68ff892f41eb0.tar.bz2
gentoo-e53aeee07189201914a71b73dca68ff892f41eb0.zip
dev-ros/global_planner: Bump to 1.16.3.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/global_planner/global_planner-1.16.3.ebuild')
-rw-r--r--dev-ros/global_planner/global_planner-1.16.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/global_planner/global_planner-1.16.3.ebuild b/dev-ros/global_planner/global_planner-1.16.3.ebuild
new file mode 100644
index 000000000000..d0530a169af8
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-1.16.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+
+ dev-ros/angles
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"