summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:36:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:36:52 +0200
commit2b971e7fc66f10d425c5a9dbd0982a2368e1b5d1 (patch)
tree854fce49cb23634331df8565f9ec790abf63a82c /dev-ros/hardware_interface/hardware_interface-0.9.3.ebuild
parentdev-ros/gazebo_ros: Initial import. Ebuild by me. (diff)
downloadgentoo-2b971e7fc66f10d425c5a9dbd0982a2368e1b5d1.tar.gz
gentoo-2b971e7fc66f10d425c5a9dbd0982a2368e1b5d1.tar.bz2
gentoo-2b971e7fc66f10d425c5a9dbd0982a2368e1b5d1.zip
dev-ros/hardware_interface: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/hardware_interface/hardware_interface-0.9.3.ebuild')
-rw-r--r--dev-ros/hardware_interface/hardware_interface-0.9.3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/hardware_interface/hardware_interface-0.9.3.ebuild b/dev-ros/hardware_interface/hardware_interface-0.9.3.ebuild
new file mode 100644
index 000000000000..d7aebeb45024
--- /dev/null
+++ b/dev-ros/hardware_interface/hardware_interface-0.9.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Hardware Interface base class"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"