summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-28 15:50:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-28 15:56:18 +0200
commit73c930f89b015fcbb6852ceb0f707285b0b4eecd (patch)
tree58681c6f9da91a0ec8521d2bfe5090845ca697ad /dev-ros/hector_geotiff/hector_geotiff-0.3.5.ebuild
parentdev-ros/hector_trajectory_server: Bump to 0.3.5. (diff)
downloadgentoo-73c930f89b015fcbb6852ceb0f707285b0b4eecd.tar.gz
gentoo-73c930f89b015fcbb6852ceb0f707285b0b4eecd.tar.bz2
gentoo-73c930f89b015fcbb6852ceb0f707285b0b4eecd.zip
dev-ros/hector_geotiff: Bump to 0.3.5.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/hector_geotiff/hector_geotiff-0.3.5.ebuild')
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-0.3.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/hector_geotiff/hector_geotiff-0.3.5.ebuild b/dev-ros/hector_geotiff/hector_geotiff-0.3.5.ebuild
new file mode 100644
index 000000000000..981460dc4e6d
--- /dev/null
+++ b/dev-ros/hector_geotiff/hector_geotiff-0.3.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Node to save occupancy grid map, robot trajectory and object of interest data to GeoTiff images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_map_tools
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"