summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 18:21:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 18:31:03 +0200
commit6bd1392c7038db03414fe58055656f9f099c0ed7 (patch)
treead2c3a58ff6efe62a0f10bd6c57b8cd99b47a5aa /dev-ros/hector_mapping/hector_mapping-0.4.1.ebuild
parentdev-ros/hector_imu_attitude_to_tf: Bump to 0.4.1. (diff)
downloadgentoo-6bd1392c7038db03414fe58055656f9f099c0ed7.tar.gz
gentoo-6bd1392c7038db03414fe58055656f9f099c0ed7.tar.bz2
gentoo-6bd1392c7038db03414fe58055656f9f099c0ed7.zip
dev-ros/hector_mapping: Bump to 0.4.1.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_mapping/hector_mapping-0.4.1.ebuild')
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.4.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/hector_mapping-0.4.1.ebuild b/dev-ros/hector_mapping/hector_mapping-0.4.1.ebuild
new file mode 100644
index 000000000000..071ffb576190
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM that can be used without odometry and on platforms that exhibit roll/pitch"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"