summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 10:59:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:16 +0200
commit196488853017b9ba3990fddf9e9063a7c09c0759 (patch)
treec3a62d501bedde66bd1f928bf30b96f0cde9d115 /dev-ros/hector_mapping
parentdev-ros/hector_imu_attitude_to_tf: Bump to 0.5.2. (diff)
downloadgentoo-196488853017b9ba3990fddf9e9063a7c09c0759.tar.gz
gentoo-196488853017b9ba3990fddf9e9063a7c09c0759.tar.bz2
gentoo-196488853017b9ba3990fddf9e9063a7c09c0759.zip
dev-ros/hector_mapping: Bump to 0.5.2.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_mapping')
-rw-r--r--dev-ros/hector_mapping/Manifest1
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/Manifest b/dev-ros/hector_mapping/Manifest
index 5621bc8ca341..20831f1311fc 100644
--- a/dev-ros/hector_mapping/Manifest
+++ b/dev-ros/hector_mapping/Manifest
@@ -1,3 +1,4 @@
DIST hector_slam-0.4.1.tar.gz 66772 BLAKE2B ad6f5596ea1fca2ed68017534280a4d622179de8df4c039e95f3e87a0e591212944d65e4d507194eb33584f7f55cba4fe398b19f5a22bfb3afce1b2406d1635d SHA512 bd0932971114f13c41c6e346756f2c95cc0a9a011d11202792a6f837757a144355e05c3e7ed1afa574b743166a78f1a7855c5693b0c57378611e50c386c2483e
DIST hector_slam-0.5.0.tar.gz 160320 BLAKE2B 9109b81740296aada8b0987d153774ac547cf063546973e8034849a5c81117c10047c12ca65f15feae5355c35a6e746cbf0ab8fa2089d282beb1f7aa06528254 SHA512 d9d7e0e7de96330358bcd98de2083ee67e0d232d6758599291607951696aef5dd93b335252448ddec59202627f69fd5a9122c0f3a2829744b4b6417906aab3ed
DIST hector_slam-0.5.1.tar.gz 160548 BLAKE2B 7a4cf8f0c1a387c4de08620478c8954df27a3ae6d23b1f11bf8574a1f62f8e742934cfb08d278e881dfb73941be89de43fe97813c992f9aa53a97487b0ae2efb SHA512 b46131a4ba3bc1eaef27091040a29f4b0f7d1a80f54e2f2756f13e08ef4d4b37ad4fef2802737bb31afe7cbbbf0e49573b87d7df991e7a19e80219a4158e3064
+DIST hector_slam-0.5.2.tar.gz 161865 BLAKE2B b9dbff17e53f2a28c0f918ff74050b2b479f4afad3acddd853a387e6cf066a0f75ff0a4b59fe212889598a65b04a08ca18a03d8cedb2b42187ec36b6f2dd03cd SHA512 62e5a74d5bc29c2fe8adc3d9d138282af6ef9d4390b44bae42a772a97a69d4f1a3d79acad0845f7bfbfddb43db6ca9b17a7b03921829643a51f44b25c2170baf
diff --git a/dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild b/dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild
new file mode 100644
index 000000000000..f3266ab2140e
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM that can be used without odometry and on platforms that exhibit roll/pitch"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"