summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:53:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:53:58 +0200
commitd5633c97ae6c4e9b00843643a9da79be03b237f3 (patch)
tree0abefc76167ad4b7dfbdaeab44f01038da9e4e55 /dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
parentdev-ros/hector_pose_estimation_core: Initial import. Ebuild by me. (diff)
downloadgentoo-d5633c97ae6c4e9b00843643a9da79be03b237f3.tar.gz
gentoo-d5633c97ae6c4e9b00843643a9da79be03b237f3.tar.bz2
gentoo-d5633c97ae6c4e9b00843643a9da79be03b237f3.zip
dev-ros/hector_pose_estimation: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild')
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
new file mode 100644
index 000000000000..702341304ef9
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_pose_estimation_core
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/message_filters
+"
+# dev-ros/hector_timing
+DEPEND="${RDEPEND}"