summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-02 13:05:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-05 11:52:05 +0200
commit0c2bb4931cdcd25f3c304b19141d9ea9fe9bf100 (patch)
tree138c0f7c5b88ec2c8333f0e0c59d681b50dd3f48 /dev-ros/hector_pose_estimation_core
parentdev-ros/hector_pose_estimation: Bump to 0.4.0. (diff)
downloadgentoo-0c2bb4931cdcd25f3c304b19141d9ea9fe9bf100.tar.gz
gentoo-0c2bb4931cdcd25f3c304b19141d9ea9fe9bf100.tar.bz2
gentoo-0c2bb4931cdcd25f3c304b19141d9ea9fe9bf100.zip
dev-ros/hector_pose_estimation_core: Bump to 0.4.0.
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_pose_estimation_core')
-rw-r--r--dev-ros/hector_pose_estimation_core/Manifest1
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.4.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation_core/Manifest b/dev-ros/hector_pose_estimation_core/Manifest
index bb841b82dd65..6730c5b1b0d6 100644
--- a/dev-ros/hector_pose_estimation_core/Manifest
+++ b/dev-ros/hector_pose_estimation_core/Manifest
@@ -1 +1,2 @@
DIST hector_localization-0.3.0.tar.gz 73656 BLAKE2B 8e895c760974f8707eb174b3b385f03f07f93f89b470d88140f1134a3cb9fb8e67e65a86484b702dbaed09e4d614f4c6759f1e08b536385f86ec15dc3db6a644 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df
+DIST hector_localization-0.4.0.tar.gz 75100 BLAKE2B afb6acb1444299c7ca47f25da7d7ad83a2363c98a6b1ed21756cdd5cf63e758b7e4e9d7ea806c7c748dc5e3606bafbe62df612a42597e86ec556696211dc8af9 SHA512 18fc8cb2f51ec978e309a627f12b896aff984fdbe2f2038c47369bd44479b3c739fad586b325c6962bb17c49e46eb7568f8af5af085fbc87749ddb2616ad34c3
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.4.0.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.4.0.ebuild
new file mode 100644
index 000000000000..f40cd89d6546
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extended Kalman Filter (EKF) that estimates the 6DOF pose of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostime
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3"