summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-20 09:35:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-22 13:27:54 +0200
commitd9ad0d57df248d755f6cc5bee2b3a127d3ee551c (patch)
tree0dfee9978ce9afd0779eb85a0560b6c7e1583de7 /dev-ros/image_geometry/image_geometry-1.13.0.ebuild
parentdev-ros/cv_bridge: Bump to 1.13.0. (diff)
downloadgentoo-d9ad0d57df248d755f6cc5bee2b3a127d3ee551c.tar.gz
gentoo-d9ad0d57df248d755f6cc5bee2b3a127d3ee551c.tar.bz2
gentoo-d9ad0d57df248d755f6cc5bee2b3a127d3ee551c.zip
dev-ros/image_geometry: Bump to 1.13.0.
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-ros/image_geometry/image_geometry-1.13.0.ebuild')
-rw-r--r--dev-ros/image_geometry/image_geometry-1.13.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/image_geometry/image_geometry-1.13.0.ebuild b/dev-ros/image_geometry/image_geometry-1.13.0.ebuild
new file mode 100644
index 000000000000..25d882f4b84d
--- /dev/null
+++ b/dev-ros/image_geometry/image_geometry-1.13.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ and Python libraries for interpreting images geometrically"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ media-libs/opencv:=
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"