summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-10 16:51:54 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-10 18:34:45 +0100
commit2f2eb55770e0a23f5e504b7a0047729ba126c3c3 (patch)
treeed8b5d86f6bb41ddc9907a0a974d537b1c41d737 /dev-ros/image_publisher/image_publisher-1.13.0.ebuild
parentdev-ros/image_proc: Bump to 1.13.0. (diff)
downloadgentoo-2f2eb55770e0a23f5e504b7a0047729ba126c3c3.tar.gz
gentoo-2f2eb55770e0a23f5e504b7a0047729ba126c3c3.tar.bz2
gentoo-2f2eb55770e0a23f5e504b7a0047729ba126c3c3.zip
dev-ros/image_publisher: Bump to 1.13.0.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_publisher/image_publisher-1.13.0.ebuild')
-rw-r--r--dev-ros/image_publisher/image_publisher-1.13.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/image_publisher/image_publisher-1.13.0.ebuild b/dev-ros/image_publisher/image_publisher-1.13.0.ebuild
new file mode 100644
index 000000000000..98088db1be94
--- /dev/null
+++ b/dev-ros/image_publisher/image_publisher-1.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Publish an image stream from single image file or avi file."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/camera_info_manager
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"