summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-26 11:30:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-26 12:03:54 +0200
commit8f5412c52db9c2bb567589f26159614e90fbf323 (patch)
treea7308e97c001cf03dab35f9fb3daacbc67edf5f9 /dev-ros/image_rotate/image_rotate-1.12.19.ebuild
parentdev-ros/image_proc: Bump to 1.12.19. (diff)
downloadgentoo-8f5412c52db9c2bb567589f26159614e90fbf323.tar.gz
gentoo-8f5412c52db9c2bb567589f26159614e90fbf323.tar.bz2
gentoo-8f5412c52db9c2bb567589f26159614e90fbf323.zip
dev-ros/image_rotate: Bump to 1.12.19.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/image_rotate/image_rotate-1.12.19.ebuild')
-rw-r--r--dev-ros/image_rotate/image_rotate-1.12.19.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/image_rotate/image_rotate-1.12.19.ebuild b/dev-ros/image_rotate/image_rotate-1.12.19.ebuild
new file mode 100644
index 000000000000..67b5cf58a8fc
--- /dev/null
+++ b/dev-ros/image_rotate/image_rotate-1.12.19.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Rotates an image stream minimizing the angle between an arbitrary vector and the camera frame"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/eigen_conversions
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+"
+DEPEND="${RDEPEND}"