summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 14:25:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 14:33:38 +0200
commit9715424c40482e7055d36e9c491e30a35b0beac9 (patch)
tree3ecfeb03aeea3f98dd09712edba82b0abf2e3f1e /dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
parentdev-ros/librviz_tutorial: Remove old (diff)
downloadgentoo-9715424c40482e7055d36e9c491e30a35b0beac9.tar.gz
gentoo-9715424c40482e7055d36e9c491e30a35b0beac9.tar.bz2
gentoo-9715424c40482e7055d36e9c491e30a35b0beac9.zip
dev-ros/interactive_marker_tutorials: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild')
-rw-r--r--dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild b/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
index 19ee9324c9d7..09550f44685e 100644
--- a/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
+++ b/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-visualization/visualization_tutorials"
KEYWORDS="~amd64"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -17,10 +16,12 @@ IUSE=""
RDEPEND="
dev-ros/roscpp
dev-ros/interactive_markers
- dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/tf[${PYTHON_USEDEP}]
dev-ros/rospy[${PYTHON_USEDEP}]
dev-ros/roslib[${PYTHON_USEDEP}]
dev-libs/boost:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"