summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 09:48:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:08 +0200
commit8afd0ac180d4a82bf7644879f22f5963f93a926f (patch)
tree1ff53aacbc058cad8c588b54a67f24909413b398 /dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
parentdev-ros/image_cb_detector: Bump to 0.10.15. (diff)
downloadgentoo-8afd0ac180d4a82bf7644879f22f5963f93a926f.tar.gz
gentoo-8afd0ac180d4a82bf7644879f22f5963f93a926f.tar.bz2
gentoo-8afd0ac180d4a82bf7644879f22f5963f93a926f.zip
dev-ros/interval_intersection: Bump to 0.10.15.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild')
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
new file mode 100644
index 000000000000..3d821a2d187a
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/actionlib
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-cpp/gtest )"