summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-07 15:21:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-07 15:39:43 +0100
commitc1619f1daa33b84f53110e71244050b21eca226a (patch)
tree60b197f157559b2cd641d0770d44caeeceb09548 /dev-ros/kdl_parser
parentdev-ros/collada_parser: remove old (diff)
downloadgentoo-c1619f1daa33b84f53110e71244050b21eca226a.tar.gz
gentoo-c1619f1daa33b84f53110e71244050b21eca226a.tar.bz2
gentoo-c1619f1daa33b84f53110e71244050b21eca226a.zip
dev-ros/kdl_parser: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/kdl_parser')
-rw-r--r--dev-ros/kdl_parser/Manifest3
-rw-r--r--dev-ros/kdl_parser/files/urdfdom1.patch34
-rw-r--r--dev-ros/kdl_parser/kdl_parser-1.12.3-r1.ebuild33
-rw-r--r--dev-ros/kdl_parser/kdl_parser-1.12.4.ebuild33
-rw-r--r--dev-ros/kdl_parser/kdl_parser-1.12.5.ebuild33
5 files changed, 0 insertions, 136 deletions
diff --git a/dev-ros/kdl_parser/Manifest b/dev-ros/kdl_parser/Manifest
index 9496381de2a6..f74e8633029b 100644
--- a/dev-ros/kdl_parser/Manifest
+++ b/dev-ros/kdl_parser/Manifest
@@ -1,4 +1 @@
-DIST robot_model-1.12.3.tar.gz 1292139 SHA256 4b2bf070e4d07450fd9977a62c260e8abb40645ff9fcf5f5781f505a8b61b194 SHA512 eae18db87bdd7fc867868493f54f1812358f1a301c88fc7eae611fa75bc2418165b5cb2f5c5839f3cb644d4c1f560f85d84b635ffbecaa631c78a3176d1fb6db WHIRLPOOL c555faee5282942db894866a08aa3a675c6db618fce2acdd1f67d622cf1c0a8e5747f5f9a5217b4fc83997f9bb9125f1c7f2ca6b77e9fd75244f121b48a77f66
-DIST robot_model-1.12.4.tar.gz 1293354 SHA256 e40bd4519fd4010bcde0cb179611a19c04c3a32073830a675090671b4cea0ee5 SHA512 f78bfd9a72d795e301836a7946d87250f4c8be2082593f7a0fb282831152bc8125885f30408ff99823c4dd1d606060b71695c1cc3097dee8870efe0fe862ab0d WHIRLPOOL cff984eec217cd4615f1bf316eaa255f0d7f2c531fede6d4764edd57a11277980b0aad87bee4af7e89b2fc56394c7d457a0bb50b103b22afc4f5f449824293e9
-DIST robot_model-1.12.5.tar.gz 1294607 SHA256 c0784cebf4b5ef38c9bf7a0f6e66f5350aa7e12460d46e2e8c4c9420b40217cc SHA512 4e1952bf9218a1ee1c09c1ff3ad607a9546675874f2d97052a1015fa1c221829e42d95c735dd136e5406fdccdbf969d55a43b318db1fed206c86c2c7a5c5ab86 WHIRLPOOL 38f0150bc4b991c7fef829e0c02c015e603d6162a3986a28433adc1d496d9098efc97f0da15cae32b8316d8677b5e156c64e36304af82f8a94a3b231a027e59c
DIST robot_model-1.12.6.tar.gz 1295666 SHA256 ac335cec5a3706a104411222a2f89ef1862c0ac8caa5ddadd390e9c25641bf27 SHA512 60270b3ec20c0473e9c8d02d661794e253405c836b06cf5c15b65dddf104bfb5e4865463e12232e94548d68eead2b5499eb04c71aee3f851fa9f85dbe733ee12 WHIRLPOOL 6cec339181a6570fbe4e61415d341f5f7404ea69d8d2a4058d5c837fa15f74c7c95a4ee3f74a78fcca624d272995f09aae4ad3a6027178b2c25daa466754adc4
diff --git a/dev-ros/kdl_parser/files/urdfdom1.patch b/dev-ros/kdl_parser/files/urdfdom1.patch
deleted file mode 100644
index c4b1d5c6e586..000000000000
--- a/dev-ros/kdl_parser/files/urdfdom1.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: kdl_parser/src/kdl_parser.cpp
-===================================================================
---- kdl_parser.orig/src/kdl_parser.cpp
-+++ kdl_parser/src/kdl_parser.cpp
-@@ -64,7 +64,7 @@ Frame toKdl(urdf::Pose p)
- }
-
- // construct joint
--Joint toKdl(boost::shared_ptr<urdf::Joint> jnt)
-+Joint toKdl(std::shared_ptr<urdf::Joint> jnt)
- {
- Frame F_parent_jnt = toKdl(jnt->parent_to_joint_origin_transform);
-
-@@ -93,7 +93,7 @@ Joint toKdl(boost::shared_ptr<urdf::Join
- }
-
- // construct inertia
--RigidBodyInertia toKdl(boost::shared_ptr<urdf::Inertial> i)
-+RigidBodyInertia toKdl(std::shared_ptr<urdf::Inertial> i)
- {
- Frame origin = toKdl(i->origin);
-
-@@ -124,9 +124,9 @@ RigidBodyInertia toKdl(boost::shared_ptr
-
-
- // recursive function to walk through tree
--bool addChildrenToTree(boost::shared_ptr<const urdf::Link> root, Tree& tree)
-+bool addChildrenToTree(std::shared_ptr<const urdf::Link> root, Tree& tree)
- {
-- std::vector<boost::shared_ptr<urdf::Link> > children = root->child_links;
-+ std::vector<std::shared_ptr<urdf::Link> > children = root->child_links;
- ROS_DEBUG("Link %s had %i children", root->name.c_str(), (int)children.size());
-
- // constructs the optional inertia
diff --git a/dev-ros/kdl_parser/kdl_parser-1.12.3-r1.ebuild b/dev-ros/kdl_parser/kdl_parser-1.12.3-r1.ebuild
deleted file mode 100644
index 7e6a2bd82278..000000000000
--- a/dev-ros/kdl_parser/kdl_parser-1.12.3-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros/robot_model"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin flag-o-matic
-
-DESCRIPTION="Constructs a KDL tree from an XML robot representation in URDF"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-ros/roscpp
- dev-ros/rosconsole
- >=dev-ros/urdf-1.12.3-r1
- sci-libs/orocos_kdl
- dev-libs/tinyxml
-"
-DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
-PATCHES=( "${FILESDIR}/urdfdom1.patch" )
-
-src_configure() {
- append-cxxflags -std=gnu++11
- ros-catkin_src_configure
-}
diff --git a/dev-ros/kdl_parser/kdl_parser-1.12.4.ebuild b/dev-ros/kdl_parser/kdl_parser-1.12.4.ebuild
deleted file mode 100644
index 7e6a2bd82278..000000000000
--- a/dev-ros/kdl_parser/kdl_parser-1.12.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros/robot_model"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin flag-o-matic
-
-DESCRIPTION="Constructs a KDL tree from an XML robot representation in URDF"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-ros/roscpp
- dev-ros/rosconsole
- >=dev-ros/urdf-1.12.3-r1
- sci-libs/orocos_kdl
- dev-libs/tinyxml
-"
-DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
-PATCHES=( "${FILESDIR}/urdfdom1.patch" )
-
-src_configure() {
- append-cxxflags -std=gnu++11
- ros-catkin_src_configure
-}
diff --git a/dev-ros/kdl_parser/kdl_parser-1.12.5.ebuild b/dev-ros/kdl_parser/kdl_parser-1.12.5.ebuild
deleted file mode 100644
index 7e6a2bd82278..000000000000
--- a/dev-ros/kdl_parser/kdl_parser-1.12.5.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros/robot_model"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin flag-o-matic
-
-DESCRIPTION="Constructs a KDL tree from an XML robot representation in URDF"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-ros/roscpp
- dev-ros/rosconsole
- >=dev-ros/urdf-1.12.3-r1
- sci-libs/orocos_kdl
- dev-libs/tinyxml
-"
-DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
-PATCHES=( "${FILESDIR}/urdfdom1.patch" )
-
-src_configure() {
- append-cxxflags -std=gnu++11
- ros-catkin_src_configure
-}