summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-23 10:34:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-23 11:01:30 +0200
commit66e11e0833936eb22fca2d640f8ab6a1a9b8b3a4 (patch)
tree2aad9a8f672474665a65155d3eb14bdc27040f3a /dev-ros/map_server/map_server-1.14.0.ebuild
parentdev-ros/global_planner: Bump to 1.14.0. (diff)
downloadgentoo-66e11e0833936eb22fca2d640f8ab6a1a9b8b3a4.tar.gz
gentoo-66e11e0833936eb22fca2d640f8ab6a1a9b8b3a4.tar.bz2
gentoo-66e11e0833936eb22fca2d640f8ab6a1a9b8b3a4.zip
dev-ros/map_server: Bump to 1.14.0.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/map_server/map_server-1.14.0.ebuild')
-rw-r--r--dev-ros/map_server/map_server-1.14.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/map_server/map_server-1.14.0.ebuild b/dev-ros/map_server/map_server-1.14.0.ebuild
new file mode 100644
index 000000000000..8cb449dff2fa
--- /dev/null
+++ b/dev-ros/map_server/map_server-1.14.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Offers map data as a ROS service"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ media-libs/sdl-image
+ >=dev-cpp/yaml-cpp-0.5
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest dev-cpp/gtest )
+ virtual/pkgconfig"