summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:31:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:36 +0200
commitf0757a9f99ecfa4f7e90168d4d718a2ba5c490e0 (patch)
tree9ba2b6c92b68aaa7a1137c4695b5d6784170a140 /dev-ros/map_server/map_server-1.17.1.ebuild
parentdev-ros/global_planner: Bump to 1.17.1. (diff)
downloadgentoo-f0757a9f99ecfa4f7e90168d4d718a2ba5c490e0.tar.gz
gentoo-f0757a9f99ecfa4f7e90168d4d718a2ba5c490e0.tar.bz2
gentoo-f0757a9f99ecfa4f7e90168d4d718a2ba5c490e0.zip
dev-ros/map_server: Bump to 1.17.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/map_server/map_server-1.17.1.ebuild')
-rw-r--r--dev-ros/map_server/map_server-1.17.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/map_server/map_server-1.17.1.ebuild b/dev-ros/map_server/map_server-1.17.1.ebuild
new file mode 100644
index 000000000000..01d98e8306e2
--- /dev/null
+++ b/dev-ros/map_server/map_server-1.17.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Offers map data as a ROS service"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ sci-physics/bullet:=
+ dev-ros/roscpp
+ media-libs/sdl-image[png]
+ dev-ros/tf2
+ >=dev-cpp/yaml-cpp-0.5:=
+
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest
+ dev-ros/rospy
+ dev-ros/rosunit
+ dev-cpp/gtest
+ )
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}