summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 15:38:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 15:39:18 +0200
commit6730028ac01ec52bc89ea63f578cdb39ab0f6048 (patch)
treec65a5c4be3fa5a8a7eca95032181bec434f14ad2 /dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7-r1.ebuild
parenteclass/ros-catkin.eclass: Export ROS_PYTHON_VERSION when building. (diff)
downloadgentoo-6730028ac01ec52bc89ea63f578cdb39ab0f6048.tar.gz
gentoo-6730028ac01ec52bc89ea63f578cdb39ab0f6048.tar.bz2
gentoo-6730028ac01ec52bc89ea63f578cdb39ab0f6048.zip
dev-ros/mavlink-gbp-release: Honour ROS_PYTHON_VERSION from eclass
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7-r1.ebuild')
-rw-r--r--dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7-r1.ebuild b/dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7-r1.ebuild
new file mode 100644
index 000000000000..86036c60a87e
--- /dev/null
+++ b/dev-ros/mavlink-gbp-release/mavlink-gbp-release-2020.7.7-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavlink-gbp-release"
+EGIT_BRANCH="release/noetic/mavlink"
+VER_PREFIX="${EGIT_BRANCH}/"
+VER_SUFFIX=-${PV#*_p}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink message marshaling library"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep "dev-python/future[\${PYTHON_USEDEP}]")"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${EGIT_BRANCH//\//-}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )