summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-07-20 13:22:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-07-20 13:23:16 +0200
commit2c146a81251ac045d27a792fc1cf80a42a3c2b9d (patch)
tree10d4ba6e14c912a4091d3cfd433a85dc3fe48610 /dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
parentdev-ros/message_filters: Remove old (diff)
downloadgentoo-2c146a81251ac045d27a792fc1cf80a42a3c2b9d.tar.gz
gentoo-2c146a81251ac045d27a792fc1cf80a42a3c2b9d.tar.bz2
gentoo-2c146a81251ac045d27a792fc1cf80a42a3c2b9d.zip
dev-ros/message_filters: upstream boost fix
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/message_filters/message_filters-1.14.3-r1.ebuild')
-rw-r--r--dev-ros/message_filters/message_filters-1.14.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild b/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
new file mode 100644
index 000000000000..48aa4d167295
--- /dev/null
+++ b/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+PYTHON_COMPAT=( python{2_7,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of message filters which take in messages and may output those messages at a later time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ dev-ros/genpy[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/boost.patch" )