summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 14:55:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 15:07:21 +0200
commit7f1aa52371eae3d81097052ed02df67574b02648 (patch)
tree93541d2160aa3d39deb5968239ea7393bea4d8ac /dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild
parentdev-ros/laser_cb_detector: Bump to 0.10.14. (diff)
downloadgentoo-7f1aa52371eae3d81097052ed02df67574b02648.tar.gz
gentoo-7f1aa52371eae3d81097052ed02df67574b02648.tar.bz2
gentoo-7f1aa52371eae3d81097052ed02df67574b02648.zip
dev-ros/monocam_settler: Bump to 0.10.14.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild')
-rw-r--r--dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild b/dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild
new file mode 100644
index 000000000000..b413582608f7
--- /dev/null
+++ b/dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Listens on a ImageFeatures topic, and waits for the data to settle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+ dev-ros/settlerlib
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"