summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-24 11:17:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-24 11:36:56 +0100
commit8a72cd8531e1e94b51a8971cae0db6bbe2203dba (patch)
treee5650213427326296fe98c7512d3ded10d2fb88c /dev-ros/monocam_settler
parentnet-misc/quagga: fix quoting in eapply call, security cleanup (diff)
downloadgentoo-8a72cd8531e1e94b51a8971cae0db6bbe2203dba.tar.gz
gentoo-8a72cd8531e1e94b51a8971cae0db6bbe2203dba.tar.bz2
gentoo-8a72cd8531e1e94b51a8971cae0db6bbe2203dba.zip
dev-ros/monocam_settler: Fix build with gcc6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/monocam_settler')
-rw-r--r--dev-ros/monocam_settler/files/gcc6.patch22
-rw-r--r--dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-ros/monocam_settler/files/gcc6.patch b/dev-ros/monocam_settler/files/gcc6.patch
new file mode 100644
index 000000000000..35c84d1fa40f
--- /dev/null
+++ b/dev-ros/monocam_settler/files/gcc6.patch
@@ -0,0 +1,22 @@
+Index: monocam_settler/CMakeLists.txt
+===================================================================
+--- monocam_settler.orig/CMakeLists.txt
++++ monocam_settler/CMakeLists.txt
+@@ -16,7 +16,7 @@ catkin_package(DEPENDS actionlib actionl
+ )
+
+
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+
+ # deal with the include
+@@ -33,7 +33,7 @@ install(TARGETS ${PROJECT_NAME}
+ )
+
+ # deal with the executable
+-include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
++include_directories(${Boost_INCLUDE_DIRS})
+ add_executable(monocam_settler_action src/monocam_settler_action.cpp)
+ target_link_libraries(monocam_settler_action ${Boost_LIBRARIES}
+ ${catkin_LIBRARIES}
diff --git a/dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild b/dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild
index b413582608f7..2352f5e16e03 100644
--- a/dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild
+++ b/dev-ros/monocam_settler/monocam_settler-0.10.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,3 +26,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gcc6.patch" )