summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:33:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:57 +0200
commitd46b0a1a6b7c9041d099a0f0cb94a21c4e414af5 (patch)
tree34ea44255036c9aa34c54b310679cdd30626b375 /dev-ros/nav_core/nav_core-1.17.0.ebuild
parentdev-ros/move_slow_and_clear: Bump to 1.17.0. (diff)
downloadgentoo-d46b0a1a6b7c9041d099a0f0cb94a21c4e414af5.tar.gz
gentoo-d46b0a1a6b7c9041d099a0f0cb94a21c4e414af5.tar.bz2
gentoo-d46b0a1a6b7c9041d099a0f0cb94a21c4e414af5.zip
dev-ros/nav_core: Bump to 1.17.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/nav_core/nav_core-1.17.0.ebuild')
-rw-r--r--dev-ros/nav_core/nav_core-1.17.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/nav_core/nav_core-1.17.0.ebuild b/dev-ros/nav_core/nav_core-1.17.0.ebuild
new file mode 100644
index 000000000000..691a5af7834c
--- /dev/null
+++ b/dev-ros/nav_core/nav_core-1.17.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Common interfaces for navigation specific robot actions"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+"
+DEPEND="${RDEPEND}"