summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-17 14:03:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-17 14:08:58 +0100
commitaf032fe310460dbdd1c2d27a688cb107c609dd34 (patch)
tree59b5f9c1bdaebb33e0ee9a8e7290d3cd9eb4148c /dev-ros/nodelet/nodelet-1.9.14.ebuild
parentsec-policy: Stabilize selinux policy 2.20170805-r3 (diff)
downloadgentoo-af032fe310460dbdd1c2d27a688cb107c609dd34.tar.gz
gentoo-af032fe310460dbdd1c2d27a688cb107c609dd34.tar.bz2
gentoo-af032fe310460dbdd1c2d27a688cb107c609dd34.zip
dev-ros/nodelet: Bump to 1.9.14.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-ros/nodelet/nodelet-1.9.14.ebuild')
-rw-r--r--dev-ros/nodelet/nodelet-1.9.14.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/nodelet/nodelet-1.9.14.ebuild b/dev-ros/nodelet/nodelet-1.9.14.ebuild
new file mode 100644
index 000000000000..f031dfcb137d
--- /dev/null
+++ b/dev-ros/nodelet/nodelet-1.9.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a way to run multiple algorithms in the same process with zero copy transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/cmake_modules
+ dev-ros/pluginlib
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-libs/boost:=
+ sys-apps/util-linux
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"