summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:29:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:52:46 +0200
commitce781d28721191aec3c680423bf51b44b7de2622 (patch)
treee2e410ddc320e1ff63cfd8053d173118237f3252 /dev-ros/nodelet/nodelet-1.9.3.ebuild
parentdev-ros/pluginlib: Initial import. Ebuild by me. (diff)
downloadgentoo-ce781d28721191aec3c680423bf51b44b7de2622.tar.gz
gentoo-ce781d28721191aec3c680423bf51b44b7de2622.tar.bz2
gentoo-ce781d28721191aec3c680423bf51b44b7de2622.zip
dev-ros/nodelet: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/nodelet/nodelet-1.9.3.ebuild')
-rw-r--r--dev-ros/nodelet/nodelet-1.9.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/nodelet/nodelet-1.9.3.ebuild b/dev-ros/nodelet/nodelet-1.9.3.ebuild
new file mode 100644
index 000000000000..e680cf52dd02
--- /dev/null
+++ b/dev-ros/nodelet/nodelet-1.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a way to run multiple algorithms in the same process with zero copy transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/cmake_modules
+ dev-ros/pluginlib
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-libs/boost:=
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"