summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-28 13:19:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-28 13:56:47 +0200
commit424b0443fb032e42b8e349200bc97349d3dd607a (patch)
tree1e852d7d0e40b1c1646bc1f7e6fb3e5b986f6309 /dev-ros/nodelet/nodelet-1.9.5.ebuild
parentros-meta/robot_model: Bump to 1.12.3. (diff)
downloadgentoo-424b0443fb032e42b8e349200bc97349d3dd607a.tar.gz
gentoo-424b0443fb032e42b8e349200bc97349d3dd607a.tar.bz2
gentoo-424b0443fb032e42b8e349200bc97349d3dd607a.zip
dev-ros/nodelet: Bump to 1.9.5.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/nodelet/nodelet-1.9.5.ebuild')
-rw-r--r--dev-ros/nodelet/nodelet-1.9.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/nodelet/nodelet-1.9.5.ebuild b/dev-ros/nodelet/nodelet-1.9.5.ebuild
new file mode 100644
index 000000000000..58e259294cee
--- /dev/null
+++ b/dev-ros/nodelet/nodelet-1.9.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a way to run multiple algorithms in the same process with zero copy transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/cmake_modules
+ dev-ros/pluginlib
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-libs/boost:=
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"