summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-14 11:57:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-14 11:57:05 +0100
commit3bef884396b88bedd6655574e24ad98a97bb9c05 (patch)
tree229a50397d33853f2339629088d7622782a6acc2 /dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild
parentdev-util/catkin: bump to 0.6.16 (diff)
downloadgentoo-3bef884396b88bedd6655574e24ad98a97bb9c05.tar.gz
gentoo-3bef884396b88bedd6655574e24ad98a97bb9c05.tar.bz2
gentoo-3bef884396b88bedd6655574e24ad98a97bb9c05.zip
dev-ros/octomap_ros: add missing dep on sci-libs/octomap. Bug #565746
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild')
-rw-r--r--dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild b/dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..7a84d61e839a
--- /dev/null
+++ b/dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/pcl_ros
+ sci-libs/octomap
+ dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"