summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-10 15:26:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-10 18:34:45 +0100
commitfa56e57dbb93d7a60683422651fd6fee528bfb76 (patch)
treec5e82c11d7b9e7b3ebbbbb1fa76290db3afd47c6 /dev-ros/opencv_apps/opencv_apps-2.0.1.ebuild
parentsci-libs/ViSP: Fix build with coin4. (diff)
downloadgentoo-fa56e57dbb93d7a60683422651fd6fee528bfb76.tar.gz
gentoo-fa56e57dbb93d7a60683422651fd6fee528bfb76.tar.bz2
gentoo-fa56e57dbb93d7a60683422651fd6fee528bfb76.zip
dev-ros/opencv_apps: bump to 2.0.1 and fix build with ocv4
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/opencv_apps/opencv_apps-2.0.1.ebuild')
-rw-r--r--dev-ros/opencv_apps/opencv_apps-2.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/opencv_apps/opencv_apps-2.0.1.ebuild b/dev-ros/opencv_apps/opencv_apps-2.0.1.ebuild
new file mode 100644
index 000000000000..74105169c2d5
--- /dev/null
+++ b/dev-ros/opencv_apps/opencv_apps-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/opencv_apps"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="OpenCV applications for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ >=media-libs/opencv-3.3:0=[contrib]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/ocv4.patch" )