summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-28 13:05:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-28 13:05:31 +0200
commit49f77d274145ec20bd075b703bb191bb1b466bbc (patch)
treea90db7b8b3acce811b64572f44b6262d64a89ba0 /dev-ros/opencv_tests/opencv_tests-1.12.2.ebuild
parentdev-ros/image_geometry: Bump to 1.12.2. (diff)
downloadgentoo-49f77d274145ec20bd075b703bb191bb1b466bbc.tar.gz
gentoo-49f77d274145ec20bd075b703bb191bb1b466bbc.tar.bz2
gentoo-49f77d274145ec20bd075b703bb191bb1b466bbc.zip
dev-ros/opencv_tests: Bump to 1.12.2.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/opencv_tests/opencv_tests-1.12.2.ebuild')
-rw-r--r--dev-ros/opencv_tests/opencv_tests-1.12.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/opencv_tests/opencv_tests-1.12.2.ebuild b/dev-ros/opencv_tests/opencv_tests-1.12.2.ebuild
new file mode 100644
index 000000000000..00dc8ea01a28
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-1.12.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}