summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-07 20:22:44 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-07 20:23:56 +0100
commit6278cb1eeadcfd16655eca739d74a8564c169ecd (patch)
tree813198f691625b197e8c971d378fb78b38318df8 /dev-ros/opencv_tests/opencv_tests-1.12.5.ebuild
parentdev-ros/image_geometry: Bump to 1.12.5. (diff)
downloadgentoo-6278cb1eeadcfd16655eca739d74a8564c169ecd.tar.gz
gentoo-6278cb1eeadcfd16655eca739d74a8564c169ecd.tar.bz2
gentoo-6278cb1eeadcfd16655eca739d74a8564c169ecd.zip
dev-ros/opencv_tests: Bump to 1.12.5.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/opencv_tests/opencv_tests-1.12.5.ebuild')
-rw-r--r--dev-ros/opencv_tests/opencv_tests-1.12.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/opencv_tests/opencv_tests-1.12.5.ebuild b/dev-ros/opencv_tests/opencv_tests-1.12.5.ebuild
new file mode 100644
index 000000000000..96b12009c607
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-1.12.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}