summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-20 09:35:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-22 13:27:55 +0200
commit825373555e16001c68e84b21758756fe18e4f5d7 (patch)
tree4bae4cc9d379dcb2f992f82ab5f13ae4d4dd3942 /dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild
parentdev-ros/image_geometry: Bump to 1.13.0. (diff)
downloadgentoo-825373555e16001c68e84b21758756fe18e4f5d7.tar.gz
gentoo-825373555e16001c68e84b21758756fe18e4f5d7.tar.bz2
gentoo-825373555e16001c68e84b21758756fe18e4f5d7.zip
dev-ros/opencv_tests: Bump to 1.13.0.
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild')
-rw-r--r--dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild b/dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild
new file mode 100644
index 000000000000..83b23217853e
--- /dev/null
+++ b/dev-ros/opencv_tests/opencv_tests-1.13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for ROS OpenCV integration"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ media-libs/opencv[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ insinto /usr/share/${PN}/launch
+ doins launch/*.launch
+ exeinto /usr/libexec/${PN}
+ doexe nodes/*
+}