summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 13:24:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 13:52:22 +0200
commitd9e320138308e37c697cac3667828740d1b84db0 (patch)
tree75fab8b5b26ebae560201bcb30e6557d7d9cf205 /dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild
parentprofiles: Adopt mask on sci-libs/mmdb:0 (diff)
downloadgentoo-d9e320138308e37c697cac3667828740d1b84db0.tar.gz
gentoo-d9e320138308e37c697cac3667828740d1b84db0.tar.bz2
gentoo-d9e320138308e37c697cac3667828740d1b84db0.zip
dev-ros/pcl_msgs: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild')
-rw-r--r--dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild b/dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild
new file mode 100644
index 000000000000..f90c2f428596
--- /dev/null
+++ b/dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros-perception/pcl_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library)-related ROS messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"