summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 17:22:27 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 17:23:12 +0100
commit0ea4258d1ca568e6491ad33262e16d230d7eae30 (patch)
tree8b5d3f77c8bc00230449882f805271987e30d093 /dev-ros/poco_vendor/poco_vendor-9999.ebuild
parentdev-ros/console_bridge_vendor: initial import (diff)
downloadgentoo-0ea4258d1ca568e6491ad33262e16d230d7eae30.tar.gz
gentoo-0ea4258d1ca568e6491ad33262e16d230d7eae30.tar.bz2
gentoo-0ea4258d1ca568e6491ad33262e16d230d7eae30.zip
dev-ros/poco_vendor: initial import
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/poco_vendor/poco_vendor-9999.ebuild')
-rw-r--r--dev-ros/poco_vendor/poco_vendor-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ros/poco_vendor/poco_vendor-9999.ebuild b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
new file mode 100644
index 000000000000..ed5cfd5207ed
--- /dev/null
+++ b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/poco_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/poco_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CMake shim over the poco library"
+HOMEPAGE="https://github.com/ros2/poco_vendor"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-libs/poco
+"
+RDEPEND="${DEPEND}"
+BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ # This is a build tool that does not install python-related files
+ # ... but we need to propagate the deps and use python3 to build it.
+ local pyimpl="${PYTHON_COMPAT[0]}"
+ python_export "${pyimpl}" EPYTHON PYTHON
+ python_wrapper_setup
+ cmake-utils_src_configure
+}