summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 12:47:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 12:48:38 +0100
commitd7b9989e496195fc97256c827fdd9896ba517835 (patch)
tree521a6ae2d6fa3480189ed7b8670a96647af72177 /dev-ros/poco_vendor/poco_vendor-9999.ebuild
parentdev-ros/console_bridge_vendor: simplify to use python-any-r1 (diff)
downloadgentoo-d7b9989e496195fc97256c827fdd9896ba517835.tar.gz
gentoo-d7b9989e496195fc97256c827fdd9896ba517835.tar.bz2
gentoo-d7b9989e496195fc97256c827fdd9896ba517835.zip
dev-ros/poco_vendor: use python-any-r1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/poco_vendor/poco_vendor-9999.ebuild')
-rw-r--r--dev-ros/poco_vendor/poco_vendor-9999.ebuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/dev-ros/poco_vendor/poco_vendor-9999.ebuild b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
index ed5cfd5207ed..b6214810f35f 100644
--- a/dev-ros/poco_vendor/poco_vendor-9999.ebuild
+++ b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -31,16 +31,7 @@ DEPEND="
dev-libs/poco
"
RDEPEND="${DEPEND}"
-BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}