summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-28 13:02:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-28 13:02:42 +0200
commitdfe7b2b07db1fba234c9824f4191983ffcbf7d8d (patch)
treeb090ad7df1dc7228933cb3ffdf0659164f179dca /dev-ros/polled_camera/polled_camera-1.11.11.ebuild
parentdev-ros/image_transport: Bump to 1.11.11. (diff)
downloadgentoo-dfe7b2b07db1fba234c9824f4191983ffcbf7d8d.tar.gz
gentoo-dfe7b2b07db1fba234c9824f4191983ffcbf7d8d.tar.bz2
gentoo-dfe7b2b07db1fba234c9824f4191983ffcbf7d8d.zip
dev-ros/polled_camera: Bump to 1.11.11.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/polled_camera/polled_camera-1.11.11.ebuild')
-rw-r--r--dev-ros/polled_camera/polled_camera-1.11.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/polled_camera/polled_camera-1.11.11.ebuild b/dev-ros/polled_camera/polled_camera-1.11.11.ebuild
new file mode 100644
index 000000000000..8d0491d278ed
--- /dev/null
+++ b/dev-ros/polled_camera/polled_camera-1.11.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="C++ helper classes for implementing a polled camera driver node and requesting images from it"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/image_transport
+ dev-ros/rosconsole
+"
+DEPEND="${RDEPEND}"