summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 11:09:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:09:38 +0200
commit29143a23301a37d3e07dcdda9c4051d3c1a678f1 (patch)
tree3d31b8c15a1e9bf2835c47b1706a7dd47d26254f /dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.0.ebuild
parentdev-ros/pr2_msgs: Bump to 1.12.0. (diff)
downloadgentoo-29143a23301a37d3e07dcdda9c4051d3c1a678f1.tar.gz
gentoo-29143a23301a37d3e07dcdda9c4051d3c1a678f1.tar.bz2
gentoo-29143a23301a37d3e07dcdda9c4051d3c1a678f1.zip
dev-ros/pr2_dashboard_aggregator: Bump to 1.12.0.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.0.ebuild')
-rw-r--r--dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.0.ebuild b/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.0.ebuild
new file mode 100644
index 000000000000..35693d7f2669
--- /dev/null
+++ b/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates all of the topics that a 'pr2_dashboard' app might be interested in"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/pr2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"