summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-22 14:54:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-22 14:56:32 +0200
commit8a4ffdd820eed237e424d40c871f94c4756298fd (patch)
treeed10501f0f4feb156288c391dc92df76f999b246 /dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.2.ebuild
parentdev-ros/pr2_msgs: Bump to 1.12.2. (diff)
downloadgentoo-8a4ffdd820eed237e424d40c871f94c4756298fd.tar.gz
gentoo-8a4ffdd820eed237e424d40c871f94c4756298fd.tar.bz2
gentoo-8a4ffdd820eed237e424d40c871f94c4756298fd.zip
dev-ros/pr2_dashboard_aggregator: Bump to 1.12.2.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.2.ebuild')
-rw-r--r--dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.2.ebuild b/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.2.ebuild
new file mode 100644
index 000000000000..52c01cd2ea3e
--- /dev/null
+++ b/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.12.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates all of the topics that a 'pr2_dashboard' app might be interested in"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/pr2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"