summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 12:58:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 12:58:47 +0100
commitb1f3ad21410f37b9042e007545ade26f8e302847 (patch)
treef5c729656df4f88fa1d9cd35aed855a44d8a6dc0 /dev-ros/qt_dotgraph/qt_dotgraph-0.3.16.ebuild
parentdev-ros/poco_vendor: use python-any-r1 (diff)
downloadgentoo-b1f3ad21410f37b9042e007545ade26f8e302847.tar.gz
gentoo-b1f3ad21410f37b9042e007545ade26f8e302847.tar.bz2
gentoo-b1f3ad21410f37b9042e007545ade26f8e302847.zip
dev-ros/qt_dotgraph: Bump to 0.3.16.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/qt_dotgraph/qt_dotgraph-0.3.16.ebuild')
-rw-r--r--dev-ros/qt_dotgraph/qt_dotgraph-0.3.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-0.3.16.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-0.3.16.ebuild
new file mode 100644
index 000000000000..84ed9c280cf1
--- /dev/null
+++ b/dev-ros/qt_dotgraph/qt_dotgraph-0.3.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helpers to work with dot graphs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ )"