summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-01 07:26:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-01 07:29:25 +0200
commit9637866122489a9c5f0757652e89025dc6bba2c2 (patch)
tree1d75a5d71d6410af596cb6033f7ec75a241c85db /dev-ros/qt_gui_py_common/qt_gui_py_common-0.2.30.ebuild
parentdev-ros/qt_gui_cpp: Bump to 0.2.30. (diff)
downloadgentoo-9637866122489a9c5f0757652e89025dc6bba2c2.tar.gz
gentoo-9637866122489a9c5f0757652e89025dc6bba2c2.tar.bz2
gentoo-9637866122489a9c5f0757652e89025dc6bba2c2.zip
dev-ros/qt_gui_py_common: Bump to 0.2.30.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/qt_gui_py_common/qt_gui_py_common-0.2.30.ebuild')
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.2.30.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.2.30.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.2.30.ebuild
new file mode 100644
index 000000000000..75a352b67b32
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.2.30.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"