summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 14:11:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:21:08 +0200
commit868b3ef7192e5a1b1ff550eab7765af360e60236 (patch)
treeee7193bc7da427246d3ec9bbaa979f695cd9e7b8 /dev-ros/qt_gui_py_common/qt_gui_py_common-0.4.2.ebuild
parentdev-ros/qt_gui_cpp: Bump to 0.4.2. (diff)
downloadgentoo-868b3ef7192e5a1b1ff550eab7765af360e60236.tar.gz
gentoo-868b3ef7192e5a1b1ff550eab7765af360e60236.tar.bz2
gentoo-868b3ef7192e5a1b1ff550eab7765af360e60236.zip
dev-ros/qt_gui_py_common: Bump to 0.4.2.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/qt_gui_py_common/qt_gui_py_common-0.4.2.ebuild')
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.4.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.4.2.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.4.2.ebuild
new file mode 100644
index 000000000000..a642b1ac2af7
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.4.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"