summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 12:33:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit5add068aaa33e3449d27b448578542f80587996b (patch)
treedaf9e663cefe518307a8367844973d49cf82a9e1 /dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild
parentdev-ros/costmap_2d: Initial import. Ebuild by me. (diff)
downloadgentoo-5add068aaa33e3449d27b448578542f80587996b.tar.gz
gentoo-5add068aaa33e3449d27b448578542f80587996b.tar.bz2
gentoo-5add068aaa33e3449d27b448578542f80587996b.zip
dev-ros/robot_pose_ekf: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild')
-rw-r--r--dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild b/dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild
new file mode 100644
index 000000000000..a2c43b164175
--- /dev/null
+++ b/dev-ros/robot_pose_ekf/robot_pose_ekf-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ sci-libs/orocos-bfl
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ virtual/pkgconfig"