summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-28 12:38:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-28 14:03:56 +0100
commit29e42ec9199cc3a050f93394f941ca97267d8875 (patch)
tree8f0b285040c3cee272b8dc887236ed6dbab94a88 /dev-ros/robot_state_publisher/robot_state_publisher-1.12.1.ebuild
parentnet-libs/libaccounts-glib: Remove old (diff)
downloadgentoo-29e42ec9199cc3a050f93394f941ca97267d8875.tar.gz
gentoo-29e42ec9199cc3a050f93394f941ca97267d8875.tar.bz2
gentoo-29e42ec9199cc3a050f93394f941ca97267d8875.zip
dev-ros/robot_state_publisher: bump to 1.12.1
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/robot_state_publisher/robot_state_publisher-1.12.1.ebuild')
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-1.12.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-1.12.1.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-1.12.1.ebuild
new file mode 100644
index 000000000000..061b1e655103
--- /dev/null
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-1.12.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_state_publisher"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Package for publishing the state of a robot to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/kdl_parser
+ dev-cpp/eigen:3
+ sci-libs/orocos_kdl
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/tf2_ros
+ dev-ros/tf2_kdl
+ dev-ros/kdl_conversions
+ dev-ros/sensor_msgs
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"