summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-04 22:38:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-04 22:38:34 +0100
commit415d3d45070acb709f0f02ac55d1484f4fcb8e5d (patch)
treeb1d9c19da1db2d219ba6d1810aab0f9f003b97b2 /dev-ros/rosapi/rosapi-0.8.5.ebuild
parentros-meta/rosserial: Bump to 0.7.7. (diff)
downloadgentoo-415d3d45070acb709f0f02ac55d1484f4fcb8e5d.tar.gz
gentoo-415d3d45070acb709f0f02ac55d1484f4fcb8e5d.tar.bz2
gentoo-415d3d45070acb709f0f02ac55d1484f4fcb8e5d.zip
dev-ros/rosapi: Bump to 0.8.5.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rosapi/rosapi-0.8.5.ebuild')
-rw-r--r--dev-ros/rosapi/rosapi-0.8.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosapi/rosapi-0.8.5.ebuild b/dev-ros/rosapi/rosapi-0.8.5.ebuild
new file mode 100644
index 000000000000..348d9a4fa5f0
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.8.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"