summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-12 20:36:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-12 20:50:59 +0200
commitb9ffe45340ec51985b20758b4fbc0034a5bf4182 (patch)
tree282bf44fed7316631a5c2393d995de67aacd69ac /dev-ros/rosapi/rosapi-0.9.0.ebuild
parentdev-ros/rosapi: Remove old (diff)
downloadgentoo-b9ffe45340ec51985b20758b4fbc0034a5bf4182.tar.gz
gentoo-b9ffe45340ec51985b20758b4fbc0034a5bf4182.tar.bz2
gentoo-b9ffe45340ec51985b20758b4fbc0034a5bf4182.zip
dev-ros/rosapi: Bump to 0.9.0.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-ros/rosapi/rosapi-0.9.0.ebuild')
-rw-r--r--dev-ros/rosapi/rosapi-0.9.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosapi/rosapi-0.9.0.ebuild b/dev-ros/rosapi/rosapi-0.9.0.ebuild
new file mode 100644
index 000000000000..b157089b594a
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"