summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 18:25:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:29:57 +0200
commit63dd063495b5c43503e68407fa307b25e4e26b39 (patch)
tree30280cc5806f907b3efba334d0a0a995c751b297 /dev-ros/rosbag/rosbag-1.15.7.ebuild
parentdev-ros/message_filters: Bump to 1.15.7. (diff)
downloadgentoo-63dd063495b5c43503e68407fa307b25e4e26b39.tar.gz
gentoo-63dd063495b5c43503e68407fa307b25e4e26b39.tar.bz2
gentoo-63dd063495b5c43503e68407fa307b25e4e26b39.zip
dev-ros/rosbag: Bump to 1.15.7.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbag/rosbag-1.15.7.ebuild')
-rw-r--r--dev-ros/rosbag/rosbag-1.15.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/rosbag/rosbag-1.15.7.ebuild b/dev-ros/rosbag/rosbag-1.15.7.ebuild
new file mode 100644
index 000000000000..572a7bcad9d9
--- /dev/null
+++ b/dev-ros/rosbag/rosbag-1.15.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE="lz4"
+
+RDEPEND="
+ >=dev-ros/rosbag_storage-1.14
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/topic_tools
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+ app-arch/bzip2
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/genpy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/console_bridge:=
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/python-gnupg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/pycrypto.patch" )