summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 18:18:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:50:32 +0200
commit2513b21133aa90acdbe114f725a909557ad1f30c (patch)
tree373af2252ad2415a43f3e148cfa7bd21dbadf6a8 /dev-ros/rosclean/rosclean-1.15.5.ebuild
parentdev-ros/rosboost_cfg: Bump to 1.15.5. (diff)
downloadgentoo-2513b21133aa90acdbe114f725a909557ad1f30c.tar.gz
gentoo-2513b21133aa90acdbe114f725a909557ad1f30c.tar.bz2
gentoo-2513b21133aa90acdbe114f725a909557ad1f30c.zip
dev-ros/rosclean: Bump to 1.15.5.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosclean/rosclean-1.15.5.ebuild')
-rw-r--r--dev-ros/rosclean/rosclean-1.15.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosclean/rosclean-1.15.5.ebuild b/dev-ros/rosclean/rosclean-1.15.5.ebuild
new file mode 100644
index 000000000000..60b255c11473
--- /dev/null
+++ b/dev-ros/rosclean/rosclean-1.15.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Cleanup filesystem resources (e.g. log files)"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"