summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 13:52:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 13:52:21 +0200
commit8b77dd010a9bd2823db4172fd8418ab3ce9f9f57 (patch)
treea9ab4cf81658377d874d66b882b7e972a061fd78 /dev-ros/rosclean/rosclean-9999.ebuild
parentdev-ros/rosbuild: Initial import. Ebuild by me. (diff)
downloadgentoo-8b77dd010a9bd2823db4172fd8418ab3ce9f9f57.tar.gz
gentoo-8b77dd010a9bd2823db4172fd8418ab3ce9f9f57.tar.bz2
gentoo-8b77dd010a9bd2823db4172fd8418ab3ce9f9f57.zip
dev-ros/rosclean: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosclean/rosclean-9999.ebuild')
-rw-r--r--dev-ros/rosclean/rosclean-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosclean/rosclean-9999.ebuild b/dev-ros/rosclean/rosclean-9999.ebuild
new file mode 100644
index 000000000000..17d830ab2ddd
--- /dev/null
+++ b/dev-ros/rosclean/rosclean-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Cleanup filesystem resources (e.g. log files)"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=( "${FILESDIR}/bb.patch" )